blob: 3560127ae43de87785c46c9c1f4179b81719e127 [file] [log] [blame]
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
PYTHON_COMPAT=( python2_7 )
inherit distutils-r1
DESCRIPTION="Framework for analyzing volatile memory"
HOMEPAGE="http://www.volatilityfoundation.org/"
#2.4.1 not on mirrors yet
#SRC_URI="http://downloads.volatilityfoundation.org/releases/${PV}/${P}.tar.gz"
SRC_URI="mirror://gentoo/${P}.tar.gz"
LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
DEPEND=""
RDEPEND=">=dev-libs/distorm64-3[${PYTHON_USEDEP}]
dev-libs/libpcre
dev-python/pycrypto[${PYTHON_USEDEP}]"
src_install() {
distutils-r1_src_install
mkdir "${D}/usr/share/${PN}"
mv "${D}/usr/contrib/plugins" "${D}/usr/share/${PN}/"
rmdir "${D}/usr/contrib"
mv "${D}/usr/tools" "${D}/usr/share/${PN}/"
dosym /usr/bin/vol.py /usr/bin/volatility
}