blob: 1a265e83be7eecd29f92da26729da347b34b3db4 [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
USE_RUBY="ruby19 ruby20 ruby21"
inherit ruby-ng
DESCRIPTION="Dictionary files for PRIME input method"
HOMEPAGE="http://taiyaki.org/prime/"
SRC_URI="http://prime.sourceforge.jp/src/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
IUSE=""
each_ruby_configure() {
econf --with-rubydir="$(ruby_rbconfig_value 'sitelibdir')" || die
}
each_ruby_compile() {
emake
}
each_ruby_install() {
emake DESTDIR="${D}" install
}
all_ruby_install() {
dodoc AUTHORS ChangeLog NEWS README
}