blob: 578e9ad53af6fc9a94cc3f8b633a00e1f11d4ca1 [file] [log] [blame]
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
OFED_VER="3.12"
OFED_RC="1"
OFED_RC_VER="1"
OFED_SUFFIX="0"
inherit openib
DESCRIPTION="NetEffect RNIC Userspace Library"
KEYWORDS="~amd64 ~x86 ~amd64-linux"
IUSE="static-libs"
DEPEND="sys-infiniband/libibverbs:${SLOT}"
RDEPEND="${DEPEND}
!sys-infiniband/openib-userspace"
block_other_ofed_versions
src_configure() {
econf $(use_enable static-libs static)
}
src_install() {
default
use static-libs || rm -f "${D}"usr/$(get_libdir)/${PN}.la
}