blob: 0588d92d2a2d7546d4471eb71e1c0e7d9c89a1b1 [file] [log] [blame]
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=4
OFED_VER="3.5"
OFED_RC="1"
OFED_RC_VER="2"
OFED_SUFFIX="1"
inherit openib
DESCRIPTION="NetEffect RNIC Userspace Library"
KEYWORDS="~amd64 ~x86 ~amd64-linux"
IUSE="static-libs"
DEPEND="sys-infiniband/libibverbs:${SLOT}"
RDEPEND="${DEPEND}
!sys-infiniband/openib-userspace"
block_other_ofed_versions
src_configure() {
econf $(use_enable static-libs static)
}
src_install() {
default
use static-libs || rm -f "${D}"usr/$(get_libdir)/${PN}.la
}