blob: 42ea3cc89ab172719d4d2138c07e20a151cad162 [file] [log] [blame]
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
inherit eutils toolchain-funcs
DESCRIPTION="Disk Information Utility"
HOMEPAGE="http://www.gentoo.com/di/"
SRC_URI="http://www.gentoo.com/di/${P}.tar.gz"
LICENSE="ZLIB"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
IUSE=""
RESTRICT="test" #405205, #405471
src_prepare() {
epatch "${FILESDIR}"/${PN}-4.33-build.patch
}
src_configure() {
emake checkbuild
emake -C C config.h
}
src_compile() {
emake prefix=/usr CC="$(tc-getCC)"
}
src_install() {
emake install prefix="${D}/usr"
# default symlink is broken
dosym di /usr/bin/mi
dodoc README
}