blob: 77dd227e897aeb4fe478911f21395252d640f223 [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=4
inherit multilib
DESCRIPTION="Library for collaborative text editing"
HOMEPAGE="http://gobby.0x539.de/"
SRC_URI="http://releases.0x539.de/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~arm ~ppc x86"
IUSE="avahi ipv6 nls static-libs"
RDEPEND="net-libs/net6
dev-libs/libsigc++:2
avahi? ( net-dns/avahi[dbus] )"
DEPEND="${RDEPEND}
nls? ( sys-devel/gettext )"
DOCS=( AUTHORS ChangeLog NEWS README TODO )
src_configure() {
econf \
$(use_with avahi zeroconf) \
$(use_enable ipv6) \
$(use_enable nls) \
$(use_enable static-libs static)
}
src_install() {
default
use static-libs || rm -f "${D}"/usr/$(get_libdir)/lib${PN}.la
}