blob: ba31068ac59b20a99996118bf764895a8a6efac5 [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
inherit autotools eutils
DESCRIPTION="NAST - Network Analyzer Sniffer Tool"
HOMEPAGE="http://sourceforge.net/projects/nast.berlios/"
SRC_URI="mirror://sourceforge/${PN}.berlios/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 x86"
IUSE="ncurses"
RDEPEND="
>=net-libs/libnet-1.1.1
net-libs/libpcap
ncurses? ( >=sys-libs/ncurses-5.4 )
"
DEPEND="
${RDEPEND}
virtual/pkgconfig
"
src_prepare() {
epatch "${FILESDIR}"/${P}-gentoo.patch
eautoreconf
}
src_compile() {
emake CFLAGS="${CFLAGS}"
}
src_install() {
dosbin nast
doman nast.8
dodoc AUTHORS BUGS CREDITS ChangeLog NCURSES_README README TODO
}