blob: 4ebcd5b34abc3fef352a34b1f0c4ad9e49cd5f2a [file] [log] [blame]
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=4
inherit eutils
DESCRIPTION="Glurp is a GTK2 based graphical client for the Music Player Daemon"
HOMEPAGE="http://sourceforge.net/projects/glurp/"
SRC_URI="mirror://sourceforge/glurp/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~ppc x86"
IUSE="debug"
RDEPEND="x11-libs/gtk+:2
>=dev-libs/glib-2.4:2
>=media-libs/libmpd-0.17"
DEPEND="${RDEPEND}
virtual/pkgconfig"
DOCS=( AUTHORS ChangeLog )
src_configure() {
econf \
$(use_enable debug)
}
src_install() {
default
doicon "${FILESDIR}"/${PN}.svg
make_desktop_entry glurp Glurp glurp AudioVideo
}