blob: 913b4d530bd660a0c75d7b33b136dbfdbde305a1 [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
DESCRIPTION="Fortune database of Terry Pratchett's Discworld related quotes"
HOMEPAGE="http://www.lspace.org/"
SRC_URI="http://www.ie.lspace.org/ftp-lspace/words/pqf/pqf-${PV}"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
IUSE=""
DEPEND="games-misc/fortune-mod"
RDEPEND="${DEPEND}"
S=${WORKDIR}
src_prepare() {
cp "${DISTDIR}"/${A} "${S}"/pqf-${PV}
}
src_compile() {
uniq "pqf-${PV}" | sed 's/^$/\%/g' > pqf
echo "%" >> pqf
strfile -r pqf || die
}
src_install() {
insinto /usr/share/fortune
doins pqf pqf.dat
}