blob: 205ce4619399d062e73f231504415f7073aa11aa [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
inherit eutils toolchain-funcs games
DESCRIPTION="ASCII space invaders clone"
HOMEPAGE="http://ninvaders.sourceforge.net/"
SRC_URI="mirror://sourceforge/ninvaders/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~ppc x86 ~x86-fbsd"
IUSE=""
DEPEND="sys-libs/ncurses:0"
RDEPEND=${DEPEND}
src_prepare() {
epatch "${FILESDIR}"/${P}-compile.patch
}
src_compile() {
emake \
CC="$(tc-getCC)" \
CFLAGS="${CFLAGS}"
}
src_install() {
newgamesbin nInvaders ninvaders
dodoc README
prepgamesdirs
}