blob: c051a7bd62a728d581d2cb6ef6f739972eb9c362 [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI="5"
PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )
inherit distutils-r1
DESCRIPTION="A comprehensive HTTP client library"
HOMEPAGE="https://code.google.com/p/httplib2/ https://pypi.python.org/pypi/httplib2"
SRC_URI="https://httplib2.googlecode.com/files/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="alpha amd64 arm ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~x64-macos"
IUSE=""
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
# tests connect to random remote sites
RESTRICT="test"
python_test() {
if [[ ${EPYTHON} == python2.7 ]] ; then
cd python2 || die
else
cd python3 || die
fi
"${PYTHON}" httplib2test.py || die
}