blob: 4743cce97d02cce306e67a678800e2845370ed22 [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
inherit toolchain-funcs
# Below is the upstream version number. The"-0" suffix should be kept in
# sync with the _p0 suffix of the ebuild version.
MY_PV=1.1.2-0
DESCRIPTION="Event handling through channels"
HOMEPAGE="http://olivinelabs.com/mediator_lua/",
SRC_URI="https://github.com/Olivine-Labs/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64"
IUSE=""
COMMON_DEPEND=">=dev-lang/lua-5.1:="
DEPEND="${COMMON_DEPEND}
virtual/pkgconfig"
RDEPEND="${COMMON_DEPEND}"
S="${WORKDIR}/${PN}-${MY_PV}"
src_install() {
insinto "$($(tc-getPKG_CONFIG) --variable INSTALL_LMOD lua)"
doins src/mediator.lua
dodoc README.md
}