blob: 444db48130823c73d23f295ce23e2421329a4925 [file] [log] [blame]
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
# ebuild generated by hackport 0.3.6.9999
#hackport: flags: +tls_1_1_3
CABAL_FEATURES="lib profile haddock hoogle hscolour"
inherit haskell-cabal
DESCRIPTION="HTTP over SSL/TLS support for Warp via the TLS package"
HOMEPAGE="https://github.com/yesodweb/wai"
SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~x86"
IUSE=""
RDEPEND=">=dev-haskell/conduit-0.5:=[profile?] <dev-haskell/conduit-1.1:=[profile?]
>=dev-haskell/cprng-aes-0.5.0:=[profile?]
>=dev-haskell/data-default-class-0.0.1:=[profile?]
>=dev-haskell/network-2.2.1:=[profile?]
>=dev-haskell/network-conduit-0.6:=[profile?] <dev-haskell/network-conduit-1.1:=[profile?]
>=dev-haskell/tls-1.2.1:=[profile?]
>=dev-haskell/transformers-0.2:=[profile?]
>=dev-haskell/wai-2.0:=[profile?] <dev-haskell/wai-2.2:=[profile?]
>=dev-haskell/warp-2.0.2:=[profile?] <dev-haskell/warp-2.2:=[profile?]
>=dev-lang/ghc-6.10.4:=
"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.6.0.3
"
src_configure() {
haskell-cabal_src_configure \
--flag=tls_1_1_3
}