blob: 6fb39d1bacee3e92c158f78751552076b310a912 [file] [log] [blame]
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI="2"
inherit toolchain-funcs
DESCRIPTION="Change the speed of your CD drive"
HOMEPAGE="http://linuxfocus.org/~guido/"
SRC_URI="http://linuxfocus.org/~guido/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="alpha amd64 ~hppa ~mips ppc x86"
IUSE=""
DEPEND=">=sys-apps/sed-4"
RDEPEND=""
src_prepare() {
sed -i Makefile \
-e 's| -o | $(LDFLAGS)&|g' \
|| die "sed Makefile failed"
}
src_compile() {
emake CFLAGS="${CFLAGS} -Wall -Wno-unused" CC=$(tc-getCC) \
|| die "emake failed"
}
src_install() {
emake PREFIX="${D}/usr" install || die "emake install"
dodoc README
}