blob: a1fbcdc21ffd0215c99e7d20696853fbb0478bec [file] [log] [blame]
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
inherit eutils scons-utils
DESCRIPTION="The SunPinyin IMEngine Wrapper for XIM Framework"
HOMEPAGE="https://sunpinyin.googlecode.com"
SRC_URI="${HOMEPAGE}/files/${P}.tar.gz"
LICENSE="LGPL-2.1 CDDL"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
DEPEND="~app-i18n/sunpinyin-2.0.3
x11-libs/gtk+:2
x11-libs/libX11"
RDEPEND="${DEPEND}"
src_prepare() {
epatch "${FILESDIR}/${P}-force-switch.patch"
}
src_compile() {
escons --prefix="/usr"
}
src_install() {
escons --prefix="/usr" --install-sandbox="${D}" install
}