blob: 38e82a682ed437468fcecc7743c44b55146d7f34 [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
inherit xfconf
DESCRIPTION="System load plug-in for Xfce panel"
HOMEPAGE="http://goodies.xfce.org/projects/panel-plugins/xfce4-systemload-plugin"
SRC_URI="mirror://xfce/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
LICENSE="BSD-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux"
IUSE="debug upower"
RDEPEND=">=x11-libs/gtk+-2.6:2=
>=xfce-base/libxfce4ui-4.10:=
>=xfce-base/libxfce4util-4.10:=
>=xfce-base/xfce4-panel-4.10:=
upower? ( || ( >=sys-power/upower-0.9.23 sys-power/upower-pm-utils ) )"
DEPEND="${RDEPEND}
dev-util/intltool
virtual/pkgconfig"
pkg_setup() {
XFCONF=(
$(use_enable upower)
$(xfconf_use_debug)
)
DOCS=( AUTHORS ChangeLog NEWS README )
}