blob: 351d40820fb7dd46aeb78f15a0bc6f83a9e22e09 [file] [log] [blame]
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=2
inherit toolchain-funcs eutils
DESCRIPTION="FUSE file system to navigate, extract, create and modify ZIP archives"
HOMEPAGE="https://bitbucket.org/agalanin/fuse-zip"
SRC_URI="https://fuse-zip.googlecode.com/files/${P}.tar.gz"
LICENSE="LGPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
DEPEND="dev-libs/libzip
sys-fs/fuse"
RDEPEND="${DEPEND}"
RESTRICT="test"
src_prepare() {
# Fix strip than installing fuse-zip
sed -i -e 's/install -m 755 -s/install -m 755/' Makefile || die "sed failed"
# fix broken makefile
epatch "${FILESDIR}"/"${P}"-as-needed.patch
# fix building with libzip-0.10
epatch "${FILESDIR}"/libzip-fix-0.10.patch
#enable parallel build
sed -i -e "s:make :\$\(MAKE\) :" Makefile || die "sed failed"
}
src_compile() {
emake CXX="$(tc-getCXX)" CXXFLAGS="${CXXFLAGS} ${LDFLAGS}" || die
}
src_install() {
emake INSTALLPREFIX="${D}"/usr install || die "Failed to install"
prepalldocs
}