blob: 8eede46c84a0e60c5c8645ca2542f23cbb3ffea3 [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI="5"
inherit toolchain-funcs flag-o-matic
DESCRIPTION="DOS filesystem tools - provides mkdosfs, mkfs.msdos, mkfs.vfat"
HOMEPAGE="http://www.daniel-baumann.ch/software/dosfstools/"
SRC_URI="https://github.com/dosfstools/dosfstools/releases/download/v${PV}/${P}.tar.xz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-linux ~arm-linux ~x86-linux"
IUSE=""
RESTRICT="test" # there is no test target #239071
src_prepare() {
sed -i \
-e "/^PREFIX/s:=.*:= ${EPREFIX}/usr:" \
-e '/^OPTFLAGS/d' \
-e '/^DEBUGFLAGS/d' \
-e "/\$(DOCDIR)/s:${PN}:${PF}:" \
Makefile || die
append-lfs-flags
tc-export CC
}