blob: 356775514c511d8f7239f27da0cf295fde45d119 [file] [log] [blame]
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
inherit eutils toolchain-funcs
DESCRIPTION="TCP/IP-based ping implementation"
HOMEPAGE="http://directory.fsf.org/security/system/poink.html"
SRC_URI="http://ep09.pld-linux.org/~mmazur/poink/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~ppc x86"
IUSE=""
DEPEND=""
src_unpack() {
unpack ${A}
epatch ${FILESDIR}/${PN}-2.03-signed-char-fixup.patch
}
src_compile() {
emake CFLAGS="${CFLAGS} ${LDFLAGS}" CC="$(tc-getCC)" || die
}
src_install() {
dobin poink poink6
newman ping.1 poink.1
dodoc README* ChangeLog COPYING
}