blob: 83e92964ed50b68437d824639b472a829207513d [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
inherit toolchain-funcs
DESCRIPTION="A small 'net top' tool, grouping bandwidth by process"
HOMEPAGE="https://github.com/raboof/nethogs"
SRC_URI="${HOMEPAGE}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~arm ~ia64 ~x86"
RDEPEND="
net-libs/libpcap
sys-libs/ncurses:0=
"
DEPEND="
${RDEPEND}
virtual/pkgconfig
"
src_compile() {
tc-export CC CXX
emake NCURSES_LIBS="$( $(tc-getPKG_CONFIG) --libs ncurses )"
}
src_install() {
emake DESTDIR="${D}" prefix="/usr" install
dodoc Changelog DESIGN README.decpcap.txt README.md
}