blob: 5f01ab76d4784ab78e4fa275b36bef7041f91446 [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
inherit vdr-plugin-2
VERSION="936" #every bump, new version
DVDARCHIVE="dvdarchive-2.3-beta.sh"
DESCRIPTION="VDR Plugin: Extended recordings menu"
HOMEPAGE="http://projects.vdr-developer.org/projects/show/plg-extrecmenu"
SRC_URI="mirror://vdr-developerorg/${VERSION}/${P}.tgz
mirror://gentoo/${DVDARCHIVE}.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 x86"
IUSE=""
DEPEND=">=media-video/vdr-1.6.0"
RDEPEND="${DEPEND}"
src_prepare() {
cd "${WORKDIR}"
epatch "${FILESDIR}/${DVDARCHIVE%.sh}-configfile.patch"
cd "${S}"
if grep -q fskProtection /usr/include/vdr/timers.h; then
einfo "Enabling parentalrating option"
sed -i "s:#WITHPINPLUGIN:WITHPINPLUGIN:" Makefile
fi
vdr-plugin-2_src_prepare
if has_version ">=media-video/vdr-1.7.28"; then
sed -i "s:SetRecording(recording->FileName(),recording->Title:SetRecording(recording->FileName:" mymenurecordings.c
fi
if has_version ">=media-video/vdr-1.7.32"; then
export EXTRECMENU_USE_VDR_CUTTER=1
einfo "disabled plugin cutter"
einfo "plugin use now the vdr included cutter"
fi
epatch "${FILESDIR}/${P}_vdr-2.1.2.diff"
}
src_install() {
vdr-plugin-2_src_install
cd "${WORKDIR}"
newbin ${DVDARCHIVE} dvdarchive.sh
insinto /etc/vdr
doins "${FILESDIR}"/dvdarchive.conf
}