blob: a6aec8b3ee9c0b82a510d5a01e8a49d678bf8c33 [file] [log] [blame]
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=3
DESCRIPTION="This plugin calls ogg123 and points it at mpd's shoutstream"
HOMEPAGE="http://gmpc.wikia.com/wiki/GMPC_PLUGIN_SHOUT"
SRC_URI="mirror://sourceforge/musicpd/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 x86"
IUSE="nls"
RDEPEND=">=media-sound/gmpc-${PV}
media-sound/vorbis-tools[ogg123]
dev-libs/libxml2
x11-libs/cairo"
DEPEND="${RDEPEND}
virtual/pkgconfig
nls? ( dev-util/intltool
sys-devel/gettext )"
src_configure() {
econf \
--disable-dependency-tracking \
$(use_enable nls)
}
src_install() {
emake DESTDIR="${D}" install || die
find "${ED}" -name "*.la" -delete || die
}