blob: 7ba87f0cf9e285aa5dc6a5d4e5774f574a4ae51d [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
PYTHON_COMPAT=( python2_7 )
PYTHON_REQ_USE="tk?"
inherit distutils-r1 games
DESCRIPTION="tintin mud client clone implemented in Python"
HOMEPAGE="http://lyntin.sourceforge.net/"
SRC_URI="mirror://sourceforge/lyntin/${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="amd64 ppc x86"
IUSE="tk"
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
RDEPEND=""
DOCS=( COMMANDS PKG-INFO HACKING README )
python_install() {
distutils-r1_python_install --install-scripts="${GAMES_BINDIR}"
}
src_prepare() {
distutils-r1_src_prepare
}
src_compile() {
distutils-r1_src_compile
}
src_install() {
distutils-r1_src_install
prepgamesdirs
}
pkg_postinst() {
games_pkg_postinst
if use tk ; then
elog "To start lyntin in GUI mode, create a config file"
elog "with this in it:"
elog
elog "[Lyntin]"
elog "ui: tk"
elog
elog "Then start lyntin like this:"
elog
elog "runlyntin -c /path/to/config_file\n"
fi
}