blob: 88522a591becf3a6c88f8fe3c7360ce3c9307daa [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
inherit autotools
MY_P="${P/_rc/-rc}"
DESCRIPTION="Linux Trace Toolkit - UST library"
HOMEPAGE="http://lttng.org"
SRC_URI="http://lttng.org/files/${PN}/${MY_P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
IUSE="examples"
DEPEND="dev-libs/userspace-rcu"
RDEPEND="${DEPEND}"
src_prepare() {
if ! use examples; then
sed -i -e '/SUBDIRS/s:examples::' doc/Makefile.am || die
fi
eautoreconf
}