blob: d7ae2b4546827b3886a0e74b163380d0f313afd5 [file] [log] [blame]
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
inherit eutils cmake-utils flag-o-matic
DESCRIPTION="find unused include directives in C/C++ programs"
HOMEPAGE="https://github.com/include-what-you-use/include-what-you-use"
# picked from google drive
SRC_URI="https://dev.gentoo.org/~slyfox/distfiles/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
RDEPEND="=sys-devel/llvm-3.3*
=sys-devel/clang-3.3*"
DEPEND="${RDEPEND}"
S=${WORKDIR}/${PN}
src_prepare() {
epatch "${FILESDIR}"/${P}-issue-110-elaboration.patch
epatch_user
}
src_configure() {
append-ldflags -L$(llvm-config --libdir)
local mycmakeargs=(
-DLLVM_PATH=$(llvm-config --libdir)
)
cmake-utils_src_configure
}