blob: 042be479d1cc4bef7749b55e9b69cf92d5fbf6b9 [file] [log] [blame]
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
ROS_REPO_URI="https://github.com/ros/diagnostics"
KEYWORDS="~amd64 ~arm"
ROS_SUBDIR=${PN}
PYTHON_COMPAT=( python2_7 )
inherit ros-catkin
DESCRIPTION="Tools for updating diagnostics"
LICENSE="BSD"
SLOT="0"
IUSE=""
RDEPEND="
dev-ros/diagnostic_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
dev-ros/roscpp
dev-ros/rostest[${PYTHON_USEDEP}]
dev-ros/std_msgs[${PYTHON_USEDEP}]
"
DEPEND="${RDEPEND}
test? ( dev-cpp/gtest dev-ros/rostest[${PYTHON_USEDEP}] )"