blob: 69c9d75b649decf03c7544c6a1fbac1035f89f55 [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
inherit qt5-build
DESCRIPTION="Hardware sensor access library for the Qt5 framework"
if [[ ${QT5_BUILD_TYPE} == release ]]; then
KEYWORDS="~amd64 ~arm ~hppa ~ppc64 ~x86"
fi
IUSE="qml"
RDEPEND="
~dev-qt/qtcore-${PV}
qml? ( ~dev-qt/qtdeclarative-${PV} )
"
DEPEND="${RDEPEND}"
src_prepare() {
qt_use_disable_mod qml quick \
src/src.pro
qt5-build_src_prepare
}