blob: d85d2be0e9f408340c05376172fa62d3c1cab9d1 [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
PYTHON_REQ_USE='sqlite'
inherit distutils-r1
DESCRIPTION="Reference implementation of the Jupyter Notebook format"
HOMEPAGE="http://jupyter.org"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="doc test"
RDEPEND="
dev-python/jsonschema[${PYTHON_USEDEP}]
dev-python/ipython_genutils[${PYTHON_USEDEP}]
dev-python/traitlets[${PYTHON_USEDEP}]
dev-python/jupyter_core[${PYTHON_USEDEP}]
"
DEPEND="${RDEPEND}
doc? (
dev-python/sphinx[${PYTHON_USEDEP}]
dev-python/numpydoc[${PYTHON_USEDEP}]
)
test? (
dev-python/nose[${PYTHON_USEDEP}]
dev-python/coverage[${PYTHON_USEDEP}]
)
"
python_prepare_all() {
# Prevent un-needed download during build
if use doc; then
sed -e "/^ 'sphinx.ext.intersphinx',/d" -i docs/conf.py || die
fi
distutils-r1_python_prepare_all
}
python_compile_all() {
use doc && emake -C docs html
}
python_test() {
distutils_install_for_testing
cd "${TEST_DIR}"/lib || die
nosetests --with-coverage --cover-package=nbformat nbformat || die
}
python_install_all() {
use doc && HTML_DOCS=( docs/_build/html/. )
distutils-r1_python_install_all
}