blob: ba242e7b0d7a946471d4dee38edae3f4e5f4b548 [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
PYTHON_COMPAT=( python2_7 python3_4 )
inherit distutils-r1
DESCRIPTION="Style checker for Sphinx (or other) RST documentation"
HOMEPAGE="http://git.openstack.org/cgit/stackforge/doc8"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="amd64 x86"
IUSE=""
CDEPEND=">=dev-python/pbr-1.6[${PYTHON_USEDEP}]"
DEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
${CDEPEND}"
RDEPEND="
${CDEPEND}
dev-python/chardet[${PYTHON_USEDEP}]
dev-python/docutils[${PYTHON_USEDEP}]
>=dev-python/restructuredtext-lint-0.7[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]
dev-python/stevedore[${PYTHON_USEDEP}]"
python_prepare_all() {
sed -i '/^argparse/d' requirements.txt || die
distutils-r1_python_prepare_all
}