blob: 9a6dea2b527822f6c68774743002d82a262e1fce [file] [log] [blame]
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
# ebuild generated by hackport 0.3.6.9999
#hackport: flags: +systemlib
CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
inherit haskell-cabal
DESCRIPTION="Backend for the persistent library using sqlite3"
HOMEPAGE="http://www.yesodweb.com/book/persistent"
SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~x86"
IUSE="build-sanity-exe"
RDEPEND=">=dev-db/sqlite-3.0
>=dev-haskell/aeson-0.5:=[profile?]
>=dev-haskell/conduit-0.5.3:=[profile?]
>=dev-haskell/monad-control-0.2:=[profile?]
>=dev-haskell/monad-logger-0.2.4:=[profile?]
>=dev-haskell/persistent-1.3:=[profile?] <dev-haskell/persistent-1.4:=[profile?]
dev-haskell/resourcet:=[profile?]
>=dev-haskell/text-0.7:=[profile?]
>=dev-haskell/transformers-0.2.1:=[profile?]
>=dev-lang/ghc-6.10.4:=
virtual/libc
"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.8
"
src_configure() {
haskell-cabal_src_configure \
$(cabal_flag build-sanity-exe build-sanity-exe) \
--flag=systemlib
}