blob: 31c90c144e4ab509a2b5a1cedd97a3f4edc09543 [file] [log] [blame]
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI="3"
inherit cmake-utils
IUSE=""
if [[ ${PV} == *9999* ]]; then
inherit git
EGIT_REPO_URI=${EGIT_REPO_URI:-"git://github.com/thewtex/tmux-mem-cpu-load.git"}
KEYWORDS=""
SRC_URI=""
else
KEYWORDS="amd64 x86"
SRC_URI="https://www.github.com/thewtex/${PN}/tarball/v${PV} -> ${P}.tar.gz"
fi
DESCRIPTION="CPU, RAM memory, and load monitor for use with tmux"
HOMEPAGE="https://github.com/thewtex/tmux-mem-cpu-load/"
LICENSE="Apache-2.0"
SLOT="0"
src_prepare() {
if [[ ${PV} == *9999* ]]; then
git_src_prepare
else
cd "${WORKDIR}"/thewtex-${PN}-*
S=$(pwd)
fi
}
src_install() {
cmake-utils_src_install
dodoc README.rst || die
}