blob: 1f5e2c60f1f8a7250834f1a403b0a983770a6f73 [file] [log] [blame]
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=4
inherit eutils toolchain-funcs flag-o-matic
DESCRIPTION="Advanced file encryption using AES"
HOMEPAGE="http://www.aescrypt.com/"
SRC_URI="https://www.aescrypt.com/download/v3/${P}.tar.gz"
LICENSE="BSD GPL-2"
SLOT="0"
KEYWORDS="~amd64"
IUSE="static"
DEPEND=""
RDEPEND="${DEPEND}"
src_prepare() {
epatch "${FILESDIR}/${P}-build.patch"
epatch "${FILESDIR}/${P}-iconv.patch"
}
src_compile() {
if use static; then
append-cflags "-DDISABLE_ICONV"
append-ldflags "-static"
fi
emake CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" CC="$(tc-getCC)"
}