blob: ba19a0d23763f2b7e64d8a7c8043689f51a5c21d [file] [log] [blame]
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI="3"
inherit eutils flag-o-matic
DESCRIPTION="Apple branch of the GNU Debugger, Xcode Tools 3.1"
HOMEPAGE="http://sourceware.org/gdb/"
SRC_URI="http://www.opensource.apple.com/darwinsource/tarballs/other/gdb-${PV}.tar.gz"
LICENSE="APSL-2 GPL-2"
SLOT="0"
KEYWORDS="~ppc-macos ~x86-macos"
IUSE="nls"
RDEPEND=">=sys-libs/ncurses-5.2-r2
=dev-db/sqlite-3*"
DEPEND="${RDEPEND}
nls? ( sys-devel/gettext )"
S=${WORKDIR}/gdb-${PV}/src
src_prepare() {
epatch "${FILESDIR}"/${PN}-768-texinfo.patch
epatch "${FILESDIR}"/${PN}-768-darwin-arch.patch
# for FSF gcc / gcc-apple:42
sed -e 's/-Wno-long-double//' -i gdb/config/*/macosx.mh
}
src_configure() {
replace-flags -O? -O2
econf \
--disable-werror \
$(use_enable nls) \
|| die
}
src_install() {
emake DESTDIR="${D}" libdir=/nukeme includedir=/nukeme install || die
rm -r "$D"/nukeme || die
rm -Rf "${ED}"/usr/${CHOST} || die
mv "${ED}"/usr/bin/gdb "${ED}"/
rm -f "${ED}"/usr/bin/*
mv "${ED}"/gdb "${ED}"/usr/bin/
}