blob: 2f058ab9b34f0ece94d2494e742241ea6a60ed9b [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
inherit autotools-utils systemd
DESCRIPTION="A simple entropy daemon using the HAVEGE algorithm"
HOMEPAGE="http://www.issihosts.com/haveged/"
SRC_URI="http://www.issihosts.com/haveged/${P}.tar.gz"
LICENSE="GPL-3+"
SLOT="0"
KEYWORDS="~amd64 ~arm ~x86"
IUSE=""
DEPEND=""
RDEPEND="!<sys-apps/openrc-0.11.8"
# threads are broken right now, but eventually
# we should add $(use_enable threads)
src_configure() {
local myeconfargs=(
--bindir=/usr/sbin
--enable-nistest
--disable-static
--disable-threads
)
autotools-utils_src_configure
}
src_install() {
autotools-utils_src_install
# Install gentoo ones instead
newinitd "${FILESDIR}"/haveged-init.d.3 haveged
newconfd "${FILESDIR}"/haveged-conf.d haveged
systemd_newunit "${FILESDIR}"/service.gentoo ${PN}.service
insinto /etc
doins "${FILESDIR}"/haveged.conf
}