blob: d50e4537a3d8623c4fa1d5fc097f1611e5aaa511 [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
USE_RUBY="ruby19 ruby20 ruby21 ruby22"
RUBY_FAKEGEM_EXTRADOC="changelog.txt Readme.md"
RUBY_FAKEGEM_RECIPE_DOC="rdoc"
inherit ruby-fakegem
DESCRIPTION="This library reads and writes .netrc files"
HOMEPAGE="https://github.com/geemus/netrc"
LICENSE="MIT"
KEYWORDS="~amd64 ~x86"
SLOT="0"
IUSE=""
all_ruby_prepare() {
sed -e '/test_encrypted_roundtrip/,/^ end/ s:^:#:' -i test/test_netrc.rb || die
}
each_ruby_test() {
${RUBY} -S testrb test/test_*.rb || die
}