blob: f7d4e773b86af0b58bc5f81ae7c85b4804f50390 [file] [log] [blame]
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
ROS_REPO_URI="https://github.com/ros-perception/calibration"
CATKIN_HAS_MESSAGES=yes
KEYWORDS="~amd64 ~arm"
PYTHON_COMPAT=( python2_7 )
ROS_SUBDIR=${PN}
inherit ros-catkin
DESCRIPTION="Reports how long a subset of joints has been settled"
LICENSE="BSD"
SLOT="0"
IUSE=""
RDEPEND="
dev-libs/boost:=[threads]
dev-ros/actionlib
dev-ros/rosconsole
dev-ros/roscpp
dev-ros/roscpp_serialization
dev-ros/settlerlib
dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
dev-ros/actionlib_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
"
DEPEND="${RDEPEND}
test? ( dev-cpp/gtest )"