blob: e9fb6f5238f0e52a7dd62fbfb7ffac39ba6c44b8 [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
inherit distutils-r1
DESCRIPTION="Sphinx spelling extension"
HOMEPAGE="https://bitbucket.org/dhellmann/sphinxcontrib-spelling"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="BSD-2"
SLOT="0"
KEYWORDS="~amd64"
IUSE="doc test"
CDEPEND="
dev-python/pbr[${PYTHON_USEDEP}]
>=dev-python/pyenchant-1.6.5[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]
>=dev-python/sphinx-0.6[${PYTHON_USEDEP}]
"
DEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
doc? ( >=dev-python/sphinx-0.6[${PYTHON_USEDEP}] )
test? (
${CDEPEND}
dev-python/nose[${PYTHON_USEDEP}]
)
"
RDEPEND="${CDEPEND}"
python_compile_all() {
use doc && emake -C docs html
}
python_test() {
nosetests || die "tests failed under ${EPYTHON}"
}
python_install_all() {
use doc && local HTML_DOCS=( docs/build/html/. )
distutils-r1_python_install_all
}