blob: 3130e1db9d4ff9c850e758c73d0a122d5f959c8f [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
inherit distutils-r1 vcs-snapshot
DESCRIPTION="Python MPD client library"
HOMEPAGE="https://github.com/Mic92/python-mpd2"
SRC_URI="https://github.com/Mic92/${PN}2/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="LGPL-3"
KEYWORDS="amd64 ~ppc ~ppc64 x86"
SLOT="0"
IUSE="test"
DEPEND="test? ( dev-python/mock[${PYTHON_USEDEP}] )
dev-python/setuptools[${PYTHON_USEDEP}]"
DOCS=( doc/changes.rst doc/topics/{advanced,commands,getting-started,logging}.rst README.rst )
python_test() {
"${PYTHON}" test.py || die "Tests fail with ${EPYTHON}"
}