blob: aa5f07d4d3afe5ad3c648f3ea3373a8059483355 [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI="5"
PYTHON_COMPAT=( python{2_7,3_3} )
inherit distutils-r1
DESCRIPTION="Python library used to edit or create SubRip files"
HOMEPAGE="https://github.com/byroot/pysrt https://pypi.python.org/pypi/pysrt"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test"
RDEPEND="
dev-python/charade[${PYTHON_USEDEP}]
"
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
test? ( dev-python/nose[coverage(+),${PYTHON_USEDEP}] )
"
# https://github.com/byroot/pysrt/issues/42
RESTRICT="test"
src_test() {
DISTUTILS_NO_PARALLEL_BUILD=1 distutils-r1_src_test
}
python_test() {
nosetests --with-coverage --cover-package=pysrt \
|| die "Tests failed under ${EPYTHON}"
}