blob: 1a1280eff6b8cce0e41c910eafe7596c84a656e8 [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
PYTHON_COMPAT=( python2_7 python3_{3,4} pypy pypy3 )
inherit distutils-r1
DESCRIPTION="Run a subprocess in a pseudo terminal"
HOMEPAGE="https://github.com/pexpect/ptyprocess"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="ISC"
SLOT="0"
KEYWORDS="amd64 arm ~hppa ~ppc ~ppc64 x86 ~amd64-linux ~x86-linux"
IUSE="test"
DEPEND="test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
python_test() {
py.test --verbose --verbose || die
}