blob: e6d95c196bcf612a463381b5fee225dcbaadbf20 [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI="4"
# NOTE: we cannot depend on autotools here starting with gcc-4.3.x
inherit eutils libtool multilib multilib-minimal
MY_PV=${PV/_p*}
MY_P=${PN}-${MY_PV}
PLEVEL=${PV/*p}
DESCRIPTION="library for multiple-precision floating-point computations with exact rounding"
HOMEPAGE="http://www.mpfr.org/"
SRC_URI="http://www.mpfr.org/mpfr-${MY_PV}/${MY_P}.tar.xz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~alpha amd64 ~arm ~arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh ~sparc x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
IUSE="static-libs"
RDEPEND=">=dev-libs/gmp-4.1.4-r2[${MULTILIB_USEDEP},static-libs?]"
DEPEND="${RDEPEND}"
S=${WORKDIR}/${MY_P}
src_prepare() {
if [[ ${PLEVEL} != ${PV} ]] ; then
local i
for (( i = 1; i <= PLEVEL; ++i )) ; do
epatch "${FILESDIR}"/${MY_PV}/patch$(printf '%02d' ${i})
done
fi
find . -type f -exec touch -r configure {} +
elibtoolize
}
multilib_src_configure() {
# Make sure mpfr doesn't go probing toolchains it shouldn't #476336#19
ECONF_SOURCE=${S} \
user_redefine_cc=yes \
econf \
--docdir="\$(datarootdir)/doc/${PF}" \
$(use_enable static-libs static)
}
multilib_src_install_all() {
use static-libs || find "${ED}"/usr -name '*.la' -delete
# clean up html/license install
pushd "${ED}"/usr/share/doc/${PF} >/dev/null
dohtml *.html && rm COPYING* *.html || die
popd >/dev/null
}
pkg_preinst() {
preserve_old_lib /usr/$(get_libdir)/libmpfr$(get_libname 1)
}
pkg_postinst() {
preserve_old_lib_notify /usr/$(get_libdir)/libmpfr$(get_libname 1)
}