blob: c64ba52a1c99499c939dfedc3f21fc9dac5b56c7 [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI="5"
GCONF_DEBUG="yes"
inherit gnome2
DESCRIPTION="GObject to SQLite object mapper library"
HOMEPAGE="https://wiki.gnome.org/Projects/Gom"
LICENSE="LGPL-2+"
SLOT="0"
IUSE="+introspection test"
KEYWORDS="~alpha amd64 ~ppc ~ppc64 ~sparc x86"
RDEPEND="
>=dev-db/sqlite-3.7:3
>=dev-libs/glib-2.36:2
introspection? ( >=dev-libs/gobject-introspection-1.30.0 )
"
DEPEND="${RDEPEND}
>=dev-util/gtk-doc-am-1.14
>=dev-util/intltool-0.40.0
sys-devel/gettext
virtual/pkgconfig
x11-libs/gdk-pixbuf
"
src_configure() {
gnome2_src_configure \
--disable-static \
$(use_enable introspection) \
$(use_enable test glibtest)
}