blob: d1217cf3b29e29b706fe9ec9f23ff9ca383f6959 [file] [log] [blame]
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=2
inherit eutils
DESCRIPTION="Collection of general purpose C++-classes"
HOMEPAGE="http://www.tntnet.org/cxxtools.hms"
SRC_URI="http://www.tntnet.org/download/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~sparc x86"
IUSE=""
RDEPEND="virtual/libiconv"
DEPEND="${RDEPEND}"
src_prepare() {
epatch "${FILESDIR}"/${P}-gcc44.patch
}
src_configure() {
econf \
--disable-dependency-tracking
}
src_install() {
emake DESTDIR="${D}" install || die "emake install failed"
dodoc AUTHORS ChangeLog
}