blob: 512c05f5fe6ffcf96f696888b34db8af8e9726df [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
KMNAME="kde-workspace"
KMMODULE="libs/kworkspace"
inherit kde4-meta
DESCRIPTION="A library for KDE desktop applications"
KEYWORDS="amd64 ~arm ppc ppc64 x86 ~x86-fbsd ~amd64-linux ~x86-linux"
IUSE="debug"
KMEXTRACTONLY="
ksmserver/org.kde.KSMServerInterface.xml
kwin/org.kde.KWin.xml
"
KMSAVELIBS="true"
DEPEND="
x11-libs/libICE
x11-libs/libSM
x11-libs/libXau
"
RDEPEND="${DEPEND}"
src_prepare() {
sed -i -e 's/install( FILES kdisplaymanager.h/install( FILES kdisplaymanager.h screenpreviewwidget.h/' \
libs/kworkspace/CMakeLists.txt || die "failed to provide screenpreviewwidget.h"
kde4-meta_src_prepare
}