blob: c65d1542b90029181cf92892c0098c8013b0e1d5 [file] [log] [blame]
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
inherit versionator eutils autotools
MY_PN=${PN/matchbox/mb}
MY_P=${MY_PN}-${PV}
DESCRIPTION="A matchbox-desktop plugin that allows you to browse and play media"
HOMEPAGE="http://matchbox-project.org/"
SRC_URI="http://matchbox-project.org/sources/${MY_PN}/$(get_version_component_range 1-2)/${MY_P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~ppc x86"
IUSE="debug"
DEPEND=">=x11-libs/libmatchbox-1.1
x11-wm/matchbox-desktop
>=media-libs/xine-lib-1.0.0"
RDEPEND="${DEPEND}"
S="${WORKDIR}/${MY_P}"
src_unpack() {
unpack ${A}
cd "${S}"
eautoreconf
}
src_compile () {
econf $(use_enable debug) || die "Configuration failed"
emake || die "Compilation failed"
}
src_install() {
make DESTDIR="${D}" install || die "Installation failed"
dodoc AUTHORS ChangeLog INSTALL NEWS README
}