blob: 7bc126b642479030663f7c104fd260a9352eb6b8 [file] [log] [blame]
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
inherit autotools eutils flag-o-matic
DESCRIPTION="A background browser and setter for X"
HOMEPAGE="http://projects.l3ib.org/nitrogen/"
SRC_URI="http://projects.l3ib.org/${PN}/files/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 x86"
IUSE="nls xinerama"
RDEPEND=">=dev-cpp/gtkmm-2.10:2.4
>=gnome-base/librsvg-2.20:2
>=x11-libs/gtk+-2.10:2
xinerama? ( x11-libs/libXinerama )"
DEPEND="${RDEPEND}
virtual/pkgconfig
nls? ( sys-devel/gettext )
xinerama? ( x11-proto/xineramaproto )"
src_prepare() {
epatch "${FILESDIR}"/${P}-gold.patch
eautoreconf
}
src_configure() {
append-cxxflags -std=c++11
econf \
$(use_enable nls) \
$(use_enable xinerama)
}