blob: ab3d3ce8e92db6dd972c4e98a78df414766d0743 [file] [log] [blame]
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=2
inherit autotools eutils
DESCRIPTION="blackbox mail notification"
HOMEPAGE="http://sourceforge.net/projects/bbtools"
SRC_URI="mirror://sourceforge/bbtools/${P}.tar.gz"
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="amd64 ppc x86 ~x86-fbsd"
IUSE=""
RDEPEND="x11-wm/blackbox
x11-libs/libX11
x11-libs/libXext"
DEPEND="${RDEPEND}
x11-proto/xproto"
src_prepare() {
epatch "${FILESDIR}"/${P}-gcc4.3.patch \
"${FILESDIR}"/${P}-gcc4.4.patch
eautoreconf
}
src_install () {
emake DESTDIR="${D}" install || die "emake install failed"
dobin scripts/bbmailparsefm.pl
dodoc AUTHORS BUGS ChangeLog INSTALL NEWS README TODO
}