blob: 34e29a36cabac08cd7da750702ba5d35160d4dc4 [file] [log] [blame]
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
inherit eutils linux-info
DESCRIPTION="Minimalistic UEFI bootloader"
HOMEPAGE="http://freedesktop.org/wiki/Software/gummiboot/"
SRC_URI="https://dev.gentoo.org/~mgorny/dist/${P}.tar.xz"
LICENSE="LGPL-2.1+"
SLOT="0"
KEYWORDS="~amd64"
IUSE=""
RDEPEND="sys-apps/util-linux"
DEPEND="${RDEPEND}
app-arch/xz-utils
app-text/docbook-xsl-stylesheets
dev-libs/libxslt
>=sys-boot/gnu-efi-3.0.2"
pkg_pretend() {
# CONFIG_EFI_STUB is required to boot a kernel with gummiboot
local CONFIG_CHECK="~EFI_STUB"
check_extra_config
}
src_prepare() {
epatch_user
}