blob: fe80f76190744ac6cc19c0499436e293bb716c88 [file] [log] [blame]
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
inherit eutils flag-o-matic toolchain-funcs multilib
SELINUX_PATCH="findutils-4.4.2-selinux.diff"
DESCRIPTION="GNU utilities for finding files"
HOMEPAGE="https://www.gnu.org/software/findutils/"
SRC_URI="mirror://gnu-alpha/${PN}/${P}.tar.gz
mirror://gnu/${PN}/${P}.tar.gz"
LICENSE="GPL-3+"
SLOT="0"
KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86"
IUSE="nls selinux static"
RDEPEND="selinux? ( sys-libs/libselinux )
nls? ( virtual/libintl )"
DEPEND="${RDEPEND}
nls? ( sys-devel/gettext )"
src_unpack() {
unpack ${A}
cd "${S}"
epatch "${FILESDIR}"/${P}-gnulib-date-x32.patch
# Don't build or install locate because it conflicts with slocate,
# which is a secure version of locate. See bug 18729
sed -i '/^SUBDIRS/s/locate//' Makefile.in
use selinux && epatch "${FILESDIR}/${SELINUX_PATCH}"
}
src_compile() {
use static && append-ldflags -static
local myconf
use userland_GNU || myconf=" --program-prefix=g"
econf \
$(use_enable nls) \
--libexecdir=/usr/$(get_libdir)/find \
${myconf} \
|| die "configure failed"
emake AR="$(tc-getAR)" || die "make failed"
}
src_install() {
emake DESTDIR="${D}" install || die
dodoc NEWS README TODO ChangeLog
}