blob: 17d44789ea2c40ffed12a9187c61d635e253981d [file] [log] [blame]
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
inherit autotools-utils
DESCRIPTION="Charset conversion library for TI calculators"
HOMEPAGE="http://lpg.ticalc.org/prj_tilp/"
SRC_URI="mirror://sourceforge/tilp/tilp2-linux/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
IUSE="doc iconv static-libs"
RDEPEND="dev-libs/glib:2"
DEPEND="${RDEPEND}
virtual/pkgconfig"
DOCS=( AUTHORS LOGO NEWS README ChangeLog docs/api.txt )
src_configure() {
local myeconfargs=(
$(use_enable iconv)
)
autotools-utils_src_configure
}
src_install() {
autotools-utils_src_install
if use doc; then
dohtml docs/html/*
docinto charsets
dohtml docs/charsets/*
fi
}